From: Larysa Zaremba <larysa.zaremba@intel.com>
To: Alexander Lobakin <aleksander.lobakin@intel.com>
Cc: bpf@vger.kernel.org, Stanislav Fomichev <sdf@google.com>,
Alexei Starovoitov <ast@kernel.org>,
Daniel Borkmann <daniel@iogearbox.net>,
Andrii Nakryiko <andrii@kernel.org>,
Jakub Kicinski <kuba@kernel.org>,
Martin KaFai Lau <martin.lau@linux.dev>,
Song Liu <song@kernel.org>, Yonghong Song <yhs@fb.com>,
John Fastabend <john.fastabend@gmail.com>,
KP Singh <kpsingh@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
Jesse Brandeburg <jesse.brandeburg@intel.com>,
Tony Nguyen <anthony.l.nguyen@intel.com>,
Anatoly Burakov <anatoly.burakov@intel.com>,
Jesper Dangaard Brouer <brouer@redhat.com>,
Alexander Lobakin <alexandr.lobakin@intel.com>,
Magnus Karlsson <magnus.karlsson@gmail.com>,
Maryam Tahhan <mtahhan@redhat.com>,
xdp-hints@xdp-project.net, netdev@vger.kernel.org,
intel-wired-lan@lists.osuosl.org, linux-kernel@vger.kernel.org
Subject: [xdp-hints] Re: [PATCH RESEND bpf-next 01/15] ice: make RX hash reading code more reusable
Date: Mon, 22 May 2023 17:03:54 +0200 [thread overview]
Message-ID: <ZGuEWl/LwtXxYgkE@lincoln> (raw)
In-Reply-To: <0c40b366-cdb5-f868-00c3-d8f485452cce@intel.com>
On Fri, May 19, 2023 at 06:46:31PM +0200, Alexander Lobakin wrote:
> From: Larysa Zaremba <larysa.zaremba@intel.com>
> Date: Fri, 12 May 2023 17:25:53 +0200
>
> > Previously, we only needed RX hash in skb path,
> > hence all related code was written with skb in mind.
> > But with the addition of XDP hints via kfuncs to the ice driver,
> > the same logic will be needed in .xmo_() callbacks.
> >
> > Separate generic process of reading RX hash from a descriptor
> > into a separate function.
> >
> > Signed-off-by: Larysa Zaremba <larysa.zaremba@intel.com>
> > ---
> > drivers/net/ethernet/intel/ice/ice_txrx_lib.c | 38 +++++++++++++------
> > 1 file changed, 27 insertions(+), 11 deletions(-)
> >
> > diff --git a/drivers/net/ethernet/intel/ice/ice_txrx_lib.c b/drivers/net/ethernet/intel/ice/ice_txrx_lib.c
> > index c8322fb6f2b3..fc67bbf600af 100644
> > --- a/drivers/net/ethernet/intel/ice/ice_txrx_lib.c
> > +++ b/drivers/net/ethernet/intel/ice/ice_txrx_lib.c
> > @@ -63,28 +63,44 @@ static enum pkt_hash_types ice_ptype_to_htype(u16 ptype)
> > }
> >
> > /**
> > - * ice_rx_hash - set the hash value in the skb
> > + * ice_copy_rx_hash_from_desc - copy hash value from descriptor to address
> > + * @rx_desc: specific descriptor
> > + * @dst: address to copy hash value to
> > + *
> > + * Returns true, if valid hash has been copied into the destination address.
> > + */
> > +static bool
> > +ice_copy_rx_hash_from_desc(union ice_32b_rx_flex_desc *rx_desc, u32 *dst)
>
> @rx_desc can be const.
Yes
>
> I'm also unsure about the naming. Why not name this one ice_rx_hash()
> and the one which sets it in skb ice_rx_hash_skb()?
I just think that
ice_copy_rx_hash_from_desc(desc, &hash, ...);
ice_copy_rx_hash_from_desc(desc, hash_ptr, ...);
communicates the intention (for a person that does not see a prototype) much
better than
ice_rx_hash(desc, &hash, ...);
ice_rx_hash(desc, hash_ptr, ...);
But now when I think about that, 'from_desc' part can probably be dropped
without little to no impact, if we also replace 'copy' with sth more
descriptive, like:
ice_read_rx_hash(desc, &hash, ...);
ice_read_rx_hash(desc, hash_ptr, ...);
Same for timestamp functions.
Probably, the main reason I started naming functions this way was
ice_get_vlan_tag_from_rx_desc().
'_from_rx_desc' part is pretty redundant there too.
I won't change '_to_skb' part though, I think function should show the direction
of change it applies.
>
> > +{
> > + struct ice_32b_rx_flex_desc_nic *nic_mdid;
>
> Also const. I thought you'll pick most of my optimizations from the
> related commit :D
Well, at some point I kinda forgot about the patch, because it wasn't very
usefult at the start of development, to be honest. Should have looked at it the
the later stages though >_<
Will make nic_mdid const.
>
> > +
> > + if (rx_desc->wb.rxdid != ICE_RXDID_FLEX_NIC)
> > + return false;
> > +
> > + nic_mdid = (struct ice_32b_rx_flex_desc_nic *)rx_desc;
> > + *dst = le32_to_cpu(nic_mdid->rss_hash);
> > + return true;
>
> You can just return the hash. `hash == 0` means there's no hash, so it
> basically means `false`, while non-zero is `true`.
Agree about both hash and timestamp.
Taking this comment and the earlier on into account, I'll name functions like
that:
ice_get_rx_hash()
ice_get_vlan_tag()
ice_ptp_get_rx_hwts_ns()
>
> > +}
> > +
> > +/**
> > + * ice_rx_hash_to_skb - set the hash value in the skb
> > * @rx_ring: descriptor ring
> > * @rx_desc: specific descriptor
> > * @skb: pointer to current skb
> > * @rx_ptype: the ptype value from the descriptor
> > */
> > static void
> > -ice_rx_hash(struct ice_rx_ring *rx_ring, union ice_32b_rx_flex_desc *rx_desc,
> > - struct sk_buff *skb, u16 rx_ptype)
> > +ice_rx_hash_to_skb(struct ice_rx_ring *rx_ring,
> > + union ice_32b_rx_flex_desc *rx_desc,
> > + struct sk_buff *skb, u16 rx_ptype)
> > {
> > - struct ice_32b_rx_flex_desc_nic *nic_mdid;
> > u32 hash;
> >
> > if (!(rx_ring->netdev->features & NETIF_F_RXHASH))
> > return;
> >
> > - if (rx_desc->wb.rxdid != ICE_RXDID_FLEX_NIC)
> > - return;
> > -
> > - nic_mdid = (struct ice_32b_rx_flex_desc_nic *)rx_desc;
> > - hash = le32_to_cpu(nic_mdid->rss_hash);
> > - skb_set_hash(skb, hash, ice_ptype_to_htype(rx_ptype));
> > + if (ice_copy_rx_hash_from_desc(rx_desc, &hash))
>
> likely()? I wouldn't care about zero-hashed frames, their perf is not
> critical anyway.
Sure.
>
> > + skb_set_hash(skb, hash, ice_ptype_to_htype(rx_ptype));
> > }
> >
> > /**
> > @@ -186,7 +202,7 @@ ice_process_skb_fields(struct ice_rx_ring *rx_ring,
> > union ice_32b_rx_flex_desc *rx_desc,
> > struct sk_buff *skb, u16 ptype)
> > {
> > - ice_rx_hash(rx_ring, rx_desc, skb, ptype);
> > + ice_rx_hash_to_skb(rx_ring, rx_desc, skb, ptype);
> >
> > /* modifies the skb - consumes the enet header */
> > skb->protocol = eth_type_trans(skb, rx_ring->netdev);
>
> Thanks,
> Olek
next prev parent reply other threads:[~2023-05-22 15:07 UTC|newest]
Thread overview: 54+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-12 15:25 [xdp-hints] [PATCH RESEND bpf-next 00/15] new kfunc XDP hints and ice implementation Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 01/15] ice: make RX hash reading code more reusable Larysa Zaremba
2023-05-19 16:46 ` [xdp-hints] " Alexander Lobakin
2023-05-22 15:03 ` Larysa Zaremba [this message]
2023-05-22 15:36 ` Alexander Lobakin
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 02/15] ice: make RX HW timestamp " Larysa Zaremba
2023-05-19 16:52 ` [xdp-hints] " Alexander Lobakin
2023-05-22 15:07 ` Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 03/15] ice: make RX checksum checking " Larysa Zaremba
2023-05-22 15:51 ` [xdp-hints] " Alexander Lobakin
2023-05-22 16:05 ` Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 04/15] ice: Make ptype internal to descriptor info processing Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 05/15] ice: Introduce ice_xdp_buff Larysa Zaremba
2023-05-22 16:46 ` [xdp-hints] " Alexander Lobakin
2023-05-23 8:02 ` Larysa Zaremba
2023-05-25 11:02 ` Alexander Lobakin
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 06/15] ice: Support HW timestamp hint Larysa Zaremba
2023-05-12 18:19 ` [xdp-hints] " Stanislav Fomichev
2023-05-16 16:17 ` Jesper Dangaard Brouer
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 07/15] ice: Support RX hash XDP hint Larysa Zaremba
2023-05-12 18:22 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:46 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 08/15] ice: Support XDP hints in AF_XDP ZC mode Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 09/15] xdp: Add VLAN tag hint Larysa Zaremba
2023-05-12 18:28 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 15:36 ` Jesper Dangaard Brouer
2023-05-15 16:09 ` Larysa Zaremba
2023-05-22 8:37 ` Jesper Dangaard Brouer
2023-05-22 15:48 ` Larysa Zaremba
2023-05-23 10:16 ` Jesper Dangaard Brouer
2023-05-23 17:35 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 10/15] ice: Implement " Larysa Zaremba
2023-05-12 18:31 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:41 ` Larysa Zaremba
2023-05-15 15:07 ` Jesper Dangaard Brouer
2023-05-15 15:45 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 11/15] xdp: Add checksum level hint Larysa Zaremba
2023-05-12 18:34 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:49 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 12/15] ice: Implement " Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 13/15] selftests/bpf: Allow VLAN packets in xdp_hw_metadata Larysa Zaremba
2023-05-12 18:33 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 14:05 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 14/15] net, xdp: allow metadata > 32 Larysa Zaremba
2023-05-15 16:17 ` [xdp-hints] " Jesper Dangaard Brouer
2023-05-15 17:08 ` Larysa Zaremba
2023-05-16 12:37 ` Alexander Lobakin
2023-05-16 15:35 ` Jesper Dangaard Brouer
2023-05-19 16:35 ` Alexander Lobakin
2023-05-22 11:41 ` Jesper Dangaard Brouer
2023-05-22 15:28 ` Alexander Lobakin
2023-05-22 15:55 ` Daniel Borkmann
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 15/15] selftests/bpf: Add flags and new hints to xdp_hw_metadata Larysa Zaremba
2023-05-12 18:37 ` [xdp-hints] " Stanislav Fomichev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
List information: https://lists.xdp-project.net/postorius/lists/xdp-hints.xdp-project.net/
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZGuEWl/LwtXxYgkE@lincoln \
--to=larysa.zaremba@intel.com \
--cc=aleksander.lobakin@intel.com \
--cc=alexandr.lobakin@intel.com \
--cc=anatoly.burakov@intel.com \
--cc=andrii@kernel.org \
--cc=anthony.l.nguyen@intel.com \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=brouer@redhat.com \
--cc=daniel@iogearbox.net \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=jesse.brandeburg@intel.com \
--cc=john.fastabend@gmail.com \
--cc=jolsa@kernel.org \
--cc=kpsingh@kernel.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=magnus.karlsson@gmail.com \
--cc=martin.lau@linux.dev \
--cc=mtahhan@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=sdf@google.com \
--cc=song@kernel.org \
--cc=xdp-hints@xdp-project.net \
--cc=yhs@fb.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox