From: Alexander Lobakin <aleksander.lobakin@intel.com>
To: Larysa Zaremba <larysa.zaremba@intel.com>
Cc: bpf@vger.kernel.org, Stanislav Fomichev <sdf@google.com>,
Alexei Starovoitov <ast@kernel.org>,
Daniel Borkmann <daniel@iogearbox.net>,
Andrii Nakryiko <andrii@kernel.org>,
Jakub Kicinski <kuba@kernel.org>,
Martin KaFai Lau <martin.lau@linux.dev>,
Song Liu <song@kernel.org>, Yonghong Song <yhs@fb.com>,
John Fastabend <john.fastabend@gmail.com>,
KP Singh <kpsingh@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
Jesse Brandeburg <jesse.brandeburg@intel.com>,
Tony Nguyen <anthony.l.nguyen@intel.com>,
Anatoly Burakov <anatoly.burakov@intel.com>,
Jesper Dangaard Brouer <brouer@redhat.com>,
Alexander Lobakin <alexandr.lobakin@intel.com>,
Magnus Karlsson <magnus.karlsson@gmail.com>,
Maryam Tahhan <mtahhan@redhat.com>,
xdp-hints@xdp-project.net, netdev@vger.kernel.org,
intel-wired-lan@lists.osuosl.org, linux-kernel@vger.kernel.org
Subject: [xdp-hints] Re: [PATCH RESEND bpf-next 05/15] ice: Introduce ice_xdp_buff
Date: Mon, 22 May 2023 18:46:40 +0200 [thread overview]
Message-ID: <7a1716ca-365f-c869-3a57-94413234fb32@intel.com> (raw)
In-Reply-To: <20230512152607.992209-6-larysa.zaremba@intel.com>
From: Larysa Zaremba <larysa.zaremba@intel.com>
Date: Fri, 12 May 2023 17:25:57 +0200
> In order to use XDP hints via kfuncs we need to put
> RX descriptor and ring pointers just next to xdp_buff.
> Same as in hints implementations in other drivers, we archieve
> this through putting xdp_buff into a child structure.
>
> Currently, xdp_buff is stored in the ring structure,
> so replace it with union that includes child structure.
> This way enough memory is available while existing XDP code
> remains isolated from hints.
>
> Size of the new child structure (ice_xdp_buff) is 72 bytes,
> therefore it does not fit into a single cache line.
> To at least place union at the start of cache line, move 'next'
> field from CL3 to CL1, as it isn't used often.
>
> Placing union at the start of cache line makes at least xdp_buff
> and descriptor fit into a single CL,
> ring pointer is used less often, so it can spill into the next CL.
Spill or span?
>
> Signed-off-by: Larysa Zaremba <larysa.zaremba@intel.com>
> ---
> drivers/net/ethernet/intel/ice/ice_txrx.c | 7 ++++--
> drivers/net/ethernet/intel/ice/ice_txrx.h | 23 ++++++++++++++++---
> drivers/net/ethernet/intel/ice/ice_txrx_lib.h | 11 +++++++++
> 3 files changed, 36 insertions(+), 5 deletions(-)
[...]
> --- a/drivers/net/ethernet/intel/ice/ice_txrx.h
> +++ b/drivers/net/ethernet/intel/ice/ice_txrx.h
> @@ -260,6 +260,15 @@ enum ice_rx_dtype {
> ICE_RX_DTYPE_SPLIT_ALWAYS = 2,
> };
>
> +struct ice_xdp_buff {
> + struct xdp_buff xdp_buff;
> + union ice_32b_rx_flex_desc *eop_desc; /* Required for all metadata */
Probably can be const here as well after changing all the places
appropriately -- I don't think you write to it anywhere.
> + /* End of the 1st cache line */
> + struct ice_rx_ring *rx_ring;
Can't we get rid of ring dependency? Maybe there's only a couple fields
that could be copied here instead of referencing the ring? I just find
it weird that our drivers often look for something in the ring structure
to parse a descriptor ._.
If not, can't it be const?
> +};
> +
> +static_assert(offsetof(struct ice_xdp_buff, xdp_buff) == 0);
> +
> /* indices into GLINT_ITR registers */
> #define ICE_RX_ITR ICE_IDX_ITR0
> #define ICE_TX_ITR ICE_IDX_ITR1
> @@ -301,7 +310,6 @@ enum ice_dynamic_itr {
> /* descriptor ring, associated with a VSI */
> struct ice_rx_ring {
> /* CL1 - 1st cacheline starts here */
> - struct ice_rx_ring *next; /* pointer to next ring in q_vector */
> void *desc; /* Descriptor ring memory */
> struct device *dev; /* Used for DMA mapping */
> struct net_device *netdev; /* netdev ring maps to */
> @@ -313,12 +321,19 @@ struct ice_rx_ring {
> u16 count; /* Number of descriptors */
> u16 reg_idx; /* HW register index of the ring */
> u16 next_to_alloc;
> - /* CL2 - 2nd cacheline starts here */
> +
> union {
> struct ice_rx_buf *rx_buf;
> struct xdp_buff **xdp_buf;
> };
> - struct xdp_buff xdp;
> + /* CL2 - 2nd cacheline starts here
> + * Size of ice_xdp_buff is 72 bytes,
> + * so it spills into CL3
> + */
> + union {
> + struct ice_xdp_buff xdp_ext;
> + struct xdp_buff xdp;
> + };
...or you can leave just one xdp_ext (naming it just "xdp") -- for now,
this union does literally nothing, as xdp_ext contains xdp at its very
beginning.
> /* CL3 - 3rd cacheline starts here */
> struct bpf_prog *xdp_prog;
> u16 rx_offset;
> @@ -328,6 +343,8 @@ struct ice_rx_ring {
> u16 next_to_clean;
> u16 first_desc;
>
> + struct ice_rx_ring *next; /* pointer to next ring in q_vector */
It can be placed even farther, somewhere near rcu_head -- IIRC it's not
used anywhere on hotpath. Even ::ring_stats below is hotter.
> +
> /* stats structs */
> struct ice_ring_stats *ring_stats;
>
> diff --git a/drivers/net/ethernet/intel/ice/ice_txrx_lib.h b/drivers/net/ethernet/intel/ice/ice_txrx_lib.h
> index e1d49e1235b3..2835a8348237 100644
> --- a/drivers/net/ethernet/intel/ice/ice_txrx_lib.h
> +++ b/drivers/net/ethernet/intel/ice/ice_txrx_lib.h
> @@ -151,4 +151,15 @@ ice_process_skb_fields(struct ice_rx_ring *rx_ring,
> struct sk_buff *skb);
> void
> ice_receive_skb(struct ice_rx_ring *rx_ring, struct sk_buff *skb, u16 vlan_tag);
> +
> +static inline void
> +ice_xdp_set_meta_srcs(struct xdp_buff *xdp,
Not sure about the naming... But can't propose anything :clownface:
ice_xdp_init_buff()? Like xdp_init_buff(), but ice_xdp_buff :D
> + union ice_32b_rx_flex_desc *eop_desc,
> + struct ice_rx_ring *rx_ring)
> +{
> + struct ice_xdp_buff *xdp_ext = (struct ice_xdp_buff *)xdp;
I'd use container_of(), even though it will do the same thing here.
BTW, is having &xdp_buff at offset 0 still a requirement?
> +
> + xdp_ext->eop_desc = eop_desc;
> + xdp_ext->rx_ring = rx_ring;
> +}
> #endif /* !_ICE_TXRX_LIB_H_ */
Thanks,
Olek
next prev parent reply other threads:[~2023-05-22 16:48 UTC|newest]
Thread overview: 54+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-12 15:25 [xdp-hints] [PATCH RESEND bpf-next 00/15] new kfunc XDP hints and ice implementation Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 01/15] ice: make RX hash reading code more reusable Larysa Zaremba
2023-05-19 16:46 ` [xdp-hints] " Alexander Lobakin
2023-05-22 15:03 ` Larysa Zaremba
2023-05-22 15:36 ` Alexander Lobakin
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 02/15] ice: make RX HW timestamp " Larysa Zaremba
2023-05-19 16:52 ` [xdp-hints] " Alexander Lobakin
2023-05-22 15:07 ` Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 03/15] ice: make RX checksum checking " Larysa Zaremba
2023-05-22 15:51 ` [xdp-hints] " Alexander Lobakin
2023-05-22 16:05 ` Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 04/15] ice: Make ptype internal to descriptor info processing Larysa Zaremba
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 05/15] ice: Introduce ice_xdp_buff Larysa Zaremba
2023-05-22 16:46 ` Alexander Lobakin [this message]
2023-05-23 8:02 ` [xdp-hints] " Larysa Zaremba
2023-05-25 11:02 ` Alexander Lobakin
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 06/15] ice: Support HW timestamp hint Larysa Zaremba
2023-05-12 18:19 ` [xdp-hints] " Stanislav Fomichev
2023-05-16 16:17 ` Jesper Dangaard Brouer
2023-05-12 15:25 ` [xdp-hints] [PATCH RESEND bpf-next 07/15] ice: Support RX hash XDP hint Larysa Zaremba
2023-05-12 18:22 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:46 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 08/15] ice: Support XDP hints in AF_XDP ZC mode Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 09/15] xdp: Add VLAN tag hint Larysa Zaremba
2023-05-12 18:28 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 15:36 ` Jesper Dangaard Brouer
2023-05-15 16:09 ` Larysa Zaremba
2023-05-22 8:37 ` Jesper Dangaard Brouer
2023-05-22 15:48 ` Larysa Zaremba
2023-05-23 10:16 ` Jesper Dangaard Brouer
2023-05-23 17:35 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 10/15] ice: Implement " Larysa Zaremba
2023-05-12 18:31 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:41 ` Larysa Zaremba
2023-05-15 15:07 ` Jesper Dangaard Brouer
2023-05-15 15:45 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 11/15] xdp: Add checksum level hint Larysa Zaremba
2023-05-12 18:34 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 13:49 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 12/15] ice: Implement " Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 13/15] selftests/bpf: Allow VLAN packets in xdp_hw_metadata Larysa Zaremba
2023-05-12 18:33 ` [xdp-hints] " Stanislav Fomichev
2023-05-15 14:05 ` Larysa Zaremba
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 14/15] net, xdp: allow metadata > 32 Larysa Zaremba
2023-05-15 16:17 ` [xdp-hints] " Jesper Dangaard Brouer
2023-05-15 17:08 ` Larysa Zaremba
2023-05-16 12:37 ` Alexander Lobakin
2023-05-16 15:35 ` Jesper Dangaard Brouer
2023-05-19 16:35 ` Alexander Lobakin
2023-05-22 11:41 ` Jesper Dangaard Brouer
2023-05-22 15:28 ` Alexander Lobakin
2023-05-22 15:55 ` Daniel Borkmann
2023-05-12 15:26 ` [xdp-hints] [PATCH RESEND bpf-next 15/15] selftests/bpf: Add flags and new hints to xdp_hw_metadata Larysa Zaremba
2023-05-12 18:37 ` [xdp-hints] " Stanislav Fomichev
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
List information: https://lists.xdp-project.net/postorius/lists/xdp-hints.xdp-project.net/
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7a1716ca-365f-c869-3a57-94413234fb32@intel.com \
--to=aleksander.lobakin@intel.com \
--cc=alexandr.lobakin@intel.com \
--cc=anatoly.burakov@intel.com \
--cc=andrii@kernel.org \
--cc=anthony.l.nguyen@intel.com \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=brouer@redhat.com \
--cc=daniel@iogearbox.net \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=jesse.brandeburg@intel.com \
--cc=john.fastabend@gmail.com \
--cc=jolsa@kernel.org \
--cc=kpsingh@kernel.org \
--cc=kuba@kernel.org \
--cc=larysa.zaremba@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=magnus.karlsson@gmail.com \
--cc=martin.lau@linux.dev \
--cc=mtahhan@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=sdf@google.com \
--cc=song@kernel.org \
--cc=xdp-hints@xdp-project.net \
--cc=yhs@fb.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox